HA Linux Install

This article will install the highly available Kato on the Linux server, which is suitable for the live environment.

Before You Start

  • Operating System:
  • Highly available shared storage.
  • Highly available databases, such as MySQL 8.0 database cluster or RDS database service, create two databases console and region.
  • ETCD cluster, can reuse the existing ETCD cluster of Kubernetes cluster.

Build Highly Available Kubernetes

Before installing Kato, a highly available Kubernetes version 1.13 and above is required. Please refer to Kubernetes High Availability Installation.

Install a Highly Available Kato Environment Based on Existing Kubernetes

For the next installation steps, see K8s-based high-availability installation.